PHP, which is a backronym for PHP: Hypertext Preprocessor, is one of the most commonly used curly-bracket programming languages available out there. Any website or web application created with PHP will run on a given web server on the condition that a PHP module is enabled, which makes the language truly universal and it isn’t really that unusual that there are several million servers that support it and 100s of millions of PHP-powered sites running on them. PHP is preferred over HTML because it allows you to develop a dynamic serving website with tons of different options. A PHP-based community portal, for example, will serve unique content to each visitor irrespective of the fact that the page URL will stay the same. By contrast, HTML sites are static and the content on the pages can be modified only manually. Like any other software program, PHP has different versions and the version that was used whilst building a particular website must be configured on the web server in order for the site to run properly.

PHP 4 and PHP 5 Support in Website Hosting

With our Linux website hosting, you will be able to choose which version of PHP will be enabled for your shared hosting account, since we support multiple versions. With as little as one mouse click, you’ll be able to switch between PHP 4, 5.2, 5.3, 5.4 and 5.5 and whenever a new version is unveiled in the future, we’ll add it to the Hepsia Control Panel without removing the previous versions. In this way, you’ll be able to host all the websites that you’ve developed through the years. In stark contrast with a lot of other hosting companies, we won’t compel you to update such sites, because a script may be outdated, but this does not necessarily mean that it is vulnerable as you may have tweaked its source code to fix security holes. For your convenience’s sake, you’ll even be able to set a different version of PHP for each individual website hosted in your shared hosting account.

PHP 4 and PHP 5 Support in Semi-dedicated Servers

In case you have a website created in an older version of PHP and you have put in time and efforts into developing it, plugging safety loopholes and posting page content, you will need a hosting service that can support it, since almost all hosting suppliers today offer support only for the latest version of PHP and remove the earlier ones. We, on the other hand, have decided to allow you to pick the version that your own sites require. Our semi-dedicated servers support PHP 4 and multiple versions of PHP 5, which suggests that you’ll be able to run both newer and older scripts without losing any manual modifications or wasting time attempting to make your sites compatible with the web hosting environment. The current version can be changed from the Hepsia Control Panel and such a change will affect the whole account, but you will also be able to pick a different version for each single website that you host in your account by means of an .htaccess file.